Jenkins Security Advisory 2024-03-20

This advisory announces vulnerabilities in the following Jenkins deliverables:

  • Jenkins (core)


HTTP/2 denial of service vulnerability in bundled Jetty

SECURITY-3379 / CVE-2024-22201
Severity (CVSS): High

Jenkins bundles Winstone-Jetty, a wrapper around Jetty, to act as HTTP and servlet server when started using java -jar jenkins.war. This is how Jenkins is run when using any of the installers or packages, but not when run using servlet containers such as Tomcat.

Jenkins 2.443 and earlier, LTS 2.440.1 and earlier bundles versions of Jetty affected by the security vulnerability CVE-2024-22201. This vulnerability allows unauthenticated attackers to cause a denial of service.

This only affects instances that enable HTTP/2, typically using the --http2Port argument to java -jar jenkins.war or corresponding options in service configuration files. It is disabled by default in all native installers and the Docker images provided by the Jenkins project.

Jenkins 2.444, LTS 2.440.2 updates the bundled Jetty to version 10.0.20, which is unaffected by these issues.

Administrators unable to update to these releases of Jenkins (or newer) are advised to disable HTTP/2.


Affected Versions

  • Jenkins weekly up to and including 2.443
  • Jenkins LTS up to and including 2.440.1


  • Jenkins weekly should be updated to version 2.444
  • Jenkins LTS should be updated to version 2.440.2

These versions include fixes to the vulnerabilities described above. All prior versions are considered to be affected by these vulnerabilities unless otherwise indicated.