Jenkins Security Advisory 2021-04-20

This advisory announces vulnerabilities in the following Jenkins deliverables:

  • Jenkins (core)


Denial of service vulnerability in bundled Jetty

JENKINS-65280 / CVE-2021-28165
Severity (CVSS): High

Jenkins bundles Winstone-Jetty, a wrapper around Jetty, to act as HTTP and servlet server when started using java -jar jenkins.war. This is how Jenkins is run when using any of the installers or packages, but not when run using servlet containers such as Tomcat.

Jenkins 2.285 and earlier, LTS 2.277.2 and earlier bundles Jetty 9.4.38 or earlier with multiple security vulnerabilities, including CVE-2021-28165. This vulnerability may allow unauthenticated attackers to cause a denial of service if Winstone-Jetty is configured to handle SSL/TLS connections.

Jenkins LTS 2.277.3 updates the bundled Jetty to 9.4.39. Jetty was already previously updated to 9.4.39 in the 2.286 weekly release.


Affected Versions

  • Jenkins weekly up to and including 2.285
  • Jenkins LTS up to and including 2.277.2


  • Jenkins weekly should be updated to version 2.286
  • Jenkins LTS should be updated to version 2.277.3

These versions include fixes to the vulnerabilities described above. All prior versions are considered to be affected by these vulnerabilities unless otherwise indicated.