This advisory announces vulnerabilities in the following Jenkins deliverables:
Script Security Plugin provides a sandbox feature that allows low privileged users to define scripts, including Pipelines, that are generally safe to execute. Calls to code defined inside a sandboxed script are intercepted, and various allowlists are checked to determine whether the call is to be allowed.
In Script Security Plugin 1.74 and earlier, any calls from outside a sandboxed script to code defined inside a sandboxed script were always allowed. As sandboxed scripts can communicate their results through script return values and similar mechanisms, this could result in code defined inside of a sandboxed script to be called without sandbox protection.
This vulnerability allows attackers with permission to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
Script Security Plugin 1.75 will prevent code defined inside a sandbox from being invoked outside a sandboxed script.
In rare cases, invocations of sandboxed scripts may begin failing if the script return value or script binding include code defined in the sandbox and is further processed by the calling code.
To resolve this issue, the affected values need to be converted inside the sandboxed script to a known safe type, such as
For compatibility with this change, the following plugins should be upgraded to the versions specified:
Warnings Plugin 5.0.1 and earlier does not require POST requests for a form validation method intended for testing custom warnings parsers, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to execute arbitrary code.
Warnings Plugin 5.0.2 requires POST requests for the affected form validation method.
This vulnerability was caused by an incomplete fix to SECURITY-1295.
Lockable Resources Plugin 2.8 and earlier does not require POST requests for several HTTP endpoints, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to reserve, unreserve, unlock, and reset resources.
Lockable Resources Plugin 2.9 requires POST requests for the affected HTTP endpoints.
Implied Labels Plugin 0.6 and earlier does not perform a permission check in an HTTP endpoint.
This allows attackers with Overall/Read permission to configure the plugin.
Implied Labels Plugin 0.7 requires Overall/Administer permission to configure the plugin.
Liquibase Runner Plugin 1.4.5 and earlier does not escape changeset contents when showing them on the build page.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide Liquibase changesets evaluated by the plugin.
Liquibase Runner Plugin 1.4.7 no longer supports evaluating changesets.
Liquibase Runner Plugin 1.4.5 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
This allows attackers able to provide Liquibase changesets evaluated by the plugin to have Jenkins parse a crafted XML file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.
Liquibase Runner Plugin 1.4.7 no longer parses Liquibase changesets.
Liquibase Runner Plugin 1.4.7 and earlier does not perform a permission check in an HTTP endpoint.
This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.
An enumeration of credentials IDs in Liquibase Runner Plugin 1.4.8 requires the appropriate permissions.
These versions include fixes to the vulnerabilities described above. All prior versions are considered to be affected by these vulnerabilities unless otherwise indicated.
The Jenkins project would like to thank the reporters for discovering and reporting these vulnerabilities: