Windows Support Policy

This page documents the Windows support policy for the Jenkins server and agents.

Scope

Jenkins plugins, e.g. WMI Windows Agents, may set additional requirements to Windows versions on masters and/or agents. This page does not document such requirements, please refer to plugin documentation.

Why?

Theoretically Jenkins can run everywhere where you can run a supported Java version, but there are some limitations in practice. Jenkins core and some plugins include native code or depend on Windows API and subsystems, and hence they rely on specific Windows platforms and versions. In the case of Windows services we also use Windows Service Wrapper (WinSW) which requires .NET Framework.

Support levels

We define multiple support levels for Windows platforms.

Support level Description Platforms

Level 1 - Full support

We run automated testing for these platforms, and we intend to timely fix the reported issues.

  • 64-bit (amd-64) Windows Server versions, with the latest GA update pack

  • Windows versions used in the official Docker images

Level 2 - Supported

We do not actively test these platforms, but we intend to keep compatibility. We are happy to accept patches.

  • 64-bit (amd-64) Windows Server versions generally supported by Microsoft

  • 64-bit (amd-64) Windows 10 versions generally supported by Microsoft

Level 3 - Patches considered

Support may have limitations and extra requirements. We do not test compatibility, and we may drop support if there is a need. We will consider patches if they do not put Level 1/2 support at risk and if they do not create maintenance overhead.

  • 64-bit Windows versions no longer supported by Microsoft

  • x86 and other non-amd64 architectures

  • Non-mainstream versions, e.g. Windows Embedded

  • Preview releases

  • Windows API emulation engines, e.g. Wine or ReactOS

Level 4 - Unsupported

These versions are known to be incompatible or to have severe limitations. We do not support the listed platforms, and we will not accept patches.

  • Windows XP older that SP3

  • Windows Phone

  • Other Windows platforms released before 2008

.NET Requirements

  • Starting from Jenkins 2.238, .NET Framework 4.0 or above is required for all Windows service installations and built-in Windows service management logic.

  • Before Jenkins 2.238, .NET Framework 2.0 was supported

  • For platforms which do not support these versions, consider using Native executables provided by the Windows Service Wrapper project.

Contributing

If you would like to add support for more Windows platforms or to share feedback, we will appreciate your contributions! Windows support in Jenkins is Platform Special Interest Group which has a chat, a mailing list and regular meetings. You are welcome to join these channels.

Version history